Unable To Open Twain Source - Canoscan Lide 25





















View All Questions

Ask a New Question

  Posted by Guest - Unable To Open Twain Source - Canoscan Lide 25 :
I'm getting an error that says unable to open twain source on my canon scanner. I'm currently using a Canon Canoscan LIDE 25 scanner. It worked before but when I connect USB on windows 7 and open canoscan toolbox (or press the scan button on the scanner which opens the same software) it keeps telling me that its unable to acquire twain source. Even when I open microsoft fax or scan software it says it can't find the twain device or scanner (dont remember exact msg on that one).

Guest Says:
I would go into your devices under system hardware and uninstall the device driver.  THen redownload from the canon website the correct driver and try again.  Reboot after reinstalling and make sure you have the right driver and 32bit or 64bit for your OS before you install it.  Also, reboot iwth the canon scanner on and plugged into the computer so it recongizes it.

Guest Says:
Still doesn't work, newest driver and it says "driver working properly" under the devices.  Same error.

Guest Says:
This worked for me, I also found this on the internet and it works because I was getting the same twain error as you:

1) Open explorer and see what your twain_32 path is.  Mine was c:\windows\twain_32\cnql25 for canoscan lide 25

Guest Says:
This worked for me, I also found this on the internet and it works because I was getting the same twain error as you:

1) Open explorer and see what your twain_32 path is.  Mine was c:\windows\twain_32\cnql25 for canoscan lide 25

2) Then go to environment variables in the control panel.  You will see it under system - advanced system settings.  Look for the button that says environment variables and click it.

3) In the bottom section under system variables, scroll down to "path" on the left and highlight that line.  Click edit.

4) Now you will see alot of paths separated by semicolons. Go all the way to the right and add to the end a semicolon, then enter c:\windows\twain_32\cnql25  and then click OK so all entries are untouched and you added that at the very end.  

5) Click ok all the way out to save and reboot, your scanner will now work fine.

Alexnder Trofivom Says:
Thanks! It works! (reboot of system is not needed =)

Guest Says:
Guest

Apotter Says:
I've seen this "fix" few times now, but I have no PATH variable in the System Variables... and since they are all alphabetically ordered, the only thing that does start with PATH is PATHEXT. Tried creating one and adding the path to the twain driver but to no avail. Before it would just say "No twain device found" now before I get that, it will also say: Cable may be disconnected or the cable may need to be replaced.. something like that, and when I close the popup, the "no twain device found" appears.
  I'm with Win7 x64 and the scanner worked fine for the past 2 years, then I had to disconnect it for a couple o weeks, and hasn't worked since. It does scan with VueScan but I don't like the results, and it's not free.

Guest Says:
thanks it works

mayank Says:
nothing

Rupesh Says:
Not Working for me
"Unable to open TWAIN source
Please check connection
Then re-start Toolbox"
i am stuck for a month now environment things all done but brought me none.
if theres something else do let know

Rupesh Says:
Guys now it works..... check this out a bit different.
http://weblogs.asp.net/jeffwids/archive/2009/11/02/canon-scanner-unable-to-open-twain-source.aspx

Guest Says:
It works for me. Thanks

anuradha Says:
Thanks
it helped a lot....

Ripandi Says:
Thanks a lot. It works fine

Jazz Says:
Hi,
Its worked without rebooting. Thank you very much.
I just wonder why the scanner stops after years of loyal services to me.
Perhaps, Canon should research this problem.

Thanks again, please continue contributing guys, people can save dollars and cents just by sharing brilliant words like this one!.

You are marvellous.

Jazz

Guest Says:
This is probably better information then what Canon Scanner support can give.  Seriously I bet their support doesn't even know how to fix this error, but this above fixes the problem.

Fizzhog Says:
Hi guys I have tried all of the above and nothing works.
I to have had no trouble for years but lately I updated all of my windows drivers and the twain problem has been there since.
Maybe its my Vista that's at fault.
I have even reloaded my CanoiScan Ver. 1.03 again but no joy.

Guest Says:
It works, thank you guys!

khan Says:
i can't use my scanner lide 25 in my win 7 it was worked before in win XP please let me know how i can use it.

Nick Says:
Yup - just don't forget the semicolon before adding the C:\Windows\twain_32\CNQL25 bit like this idiot did...


Add your reply below ...



This site allows you to ask questions and get answers from various posters. You may also answer any posts if you feel like you have input to give. Feel free to ask for help with any new question you wish, but most of the questions here are tech related. You will find many questions and answers related to your Ipod or Ipod Nano, Itunes, audio and video converting, spyware or adware cleanup, pc or other computer questions, and even mainframe questions. Although these are the tech questions most often asked, you will find help on almost any computer or software related subject. Feel free to go to the main menu and review the posts already present, or feel free to ask your own question. (Some questions will be closed once the moderator feels they are sufficiently answered and that no other input is needed).

"BlurBorder" - Get the app

  • Square any photo instantly.
  • Creates blurry border effects.
  • Also includes faded border effects.
  • For Iphone, Ipod, and Ipad.

  • Your Name:

    Your Reply:

    Type in verification code:


    Front Page

    Spyware/Task Database

    Computer Tips (Main Page)